IPv6 Freigaben verschwinden auf Fritz!Box

VonChristian Rehkopf

IPv6 Freigaben verschwinden auf Fritz!Box

IPv6 Freigaben funktionieren auf einmal auf der AVM Fritz-Box nicht mehr oder nie oder verschwinden.

Dies ist einer dieser Beiträge, die ich schreibe, damit ich etwas über Google finde, wenn ich mal wieder danach suche.

Das hat mich fast in den Wahnsinn getrieben, aber bei den IPv6 Freigaben auf der Fritzbox scheint einiges im Argen zu sein.

  1. Man kann eine einmal eingetragene Adresse nicht editieren, sondern muss den Freigabeblock löschen und komplett neu anlegen. Das kann passieren wenn:
    1. Hat man sich vertippt, und Freigaben auf einer falschen Interface-ID zugeordnet, dann muss man die Freigaben löschen und komplett neu machen.
    2. Nimmt man (um Tippfehler zu vermeiden) die Auswahlbox, kann es einem passieren, das man nicht die IPv6 verwendet, die sich aus der MAC-Adresse ableitet, sondern eine, die von der privacy extension des Betriebssystems generiert wurde. Die ist dann morgen wieder ungültig.
  2. Wenn eine IPv6 Freigabe im LAN nicht erreichbar ist, dann dauert es eine Weile bis unendlich (oder Neustart), bis diese wieder funktioniert.
    Also erstmal scheint die Box dann beleidigt, da ich aber auch mal vergessen hatte selbige neu zu starten und am nächsten Tag wieder alles ging, scheint das ein vorübergehender Schluckauf zu sein. Es ist auch schon vorgekommen das nix gut war, bis man die FB resettet hat.
  3. Wenn die Fritzbox ein Update bekommen hat, kann es durchaus passieren das die Config zwar noch da steht, aber wirkungslos ist. In Dem Fall hilft dann nicht, die IPv6 Freigeben neu zu erfassen, sondern man muss die ganze Config neu manuell eintragen (mit allen DECT-Phones, AAB, Fax, Freigaben-blah)

Grundsätzlich ist die Tipperei der IPv6-Freigaben eine Qual, denn man kann nicht mehrere IPv6 Freigaben hintereinander weg einrichten, da der Knopf „neue Freigabe“ verschwindet, nachdem man ihn mal gedrückt hat – man muss also wieder ins Freigabemenü und die ganze V6 Freigabe neu laden um wieder „neue Freigabe“ zu drücken – dieses reinrauss hat bei meiner 6490 immer 10 Sekunden Ladezeit zur Folge – das bei 8 Freigaben, dauert gefühlt eine Stunde um die Ports wieder aufzumachen.

Das das Buggy ist, hab ich AVM schon vor einem halben Jahr kommuniziert – Ticket #16098.

In dem Sinne: Happy Typing.

 

Achja – keinen Technik-Blogeintrag ohne Code – um die Richtige IPv6-Adresse an einem Debian o.ä. zu ermitteln:
ip -6 addr sh primary scope global|grep inet6|awk '{ print $2 }'|grep -v '^f'

 

Über den Autor

Christian Rehkopf administrator